[Balloon] USB Networking

Top Page
Message as email
+ (text/plain)
Delete this message
Reply to this message
Author: Chris Jones
To: Balloon
Subject: [Balloon] USB Networking
Balloon people,

Has anything changed in the USB networking/g_ether/CDC world recently?
I've just put a bleeding-edge kernel (2.6.38rc6) on a Balloon 3 and
can't get it to talk to a PC over USB. I've tried two different
machines, both of which used to work, and neither of them do now. Trying
to bring up usb0 on the PC gives me a string of 'No such device'
messages and fails. usb0 will come up on the Balloon but never gets a
DHCP reply.

I tried udevadm monitor on the PC and can't see any events which
indicate that usb0 has become available, though the right kernel modules
get automagically loaded and I can see the Loon in lsusb:
"Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget".

Has anyone else had this problem?

Chris Jones -
Martin-Jones Technology Ltd c/o Element Energy Ltd
Twenty Station Road, Cambridge, CB1 2JD, UK
Phone +44 (0) 1223 655611 Fax +44 (0) 870 112 3908